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^  →Overview

Noatikl 2 - Generative Music Composer

(/noatikl/download)

Noatikl (pronounced "noh – tickle") is a very powerful generative (MIDI (https://en.wikipedia.org/wiki/MIDI)) music creativity application. It is
the evolution of the SSEYO Koan (/sseyo/koan) Generative Music System.

Noatikl generates its MIDI notes and MIDI controller events via the integrated Noatikl (MIDI) Music Engine (/engine/nme/guide/) (NME). This
MIDI data can be used to drive 3rd party external MIDI software or hardware, such as synths, FX units and samplers, that you connect to
Noatikl, or the integrated (but optional to use) Partikl Sound Engine (/engine/pse/guide) (PSE), a powerful, advanced and modular synth + live
FX network.

Don't forget to check out the 30 second videos!

Noatikl is available for both Desktop (Windows/Mac OS X) and Mobile (iOS). Those using Desktop Audio software generally have a preferred
workflow, using either a DAW with Plugins, or using and connecting a number of Standalone apps. So that you can use Noatikl Desktop in the
way you prefer, there are 2 versions - Noatikl Desktop Standalone and the Noatikl Desktop Audio Plugins (VSTi/Aui). The Desktop versions
(only) also have extensive built-in scripting (/engine/nme/guide/#scripting) features which allow them to be used as a customisable
hyperinstruments (/engine/nme/guide/#scripting-hyperinstrument).

This guide details the various Noatikl app interface elements and what they do, as well as other kinds of application specific things such as
installation, connecting to external MIDI sources etc. When it comes to defining how the music and sounds are generated, however, we direct
you instead to the NME Guide (/engine/nme/guide) and PSE Guide (/engine/pse/guide) which cover all relevant objects, parameters and
settings available.

Quick overview on the NME and how it works

The NME utilises a range of generative / aleatoric / stochastic / algorithmic music techniques and parameters and creates MIDI notes and
MIDI controller events through the interaction of 4 different kinds of NME Objects: Voice (/engine/nme/guide/#voice-types) (with 6 Voice
Types), Rule (/engine/nme/guide/#the-rules) (Scale, Harmony, Rhythm & Next Note), Piece (/engine/nme/guide/#piece-basics) and File
(/engine/nme/guide/#file). There can be multiple instances of the first two objects in a "piece" and there are a large number of Voice Object
parameters (/engine/nme/guide/#scripting-objects) to affect and direct the composition.

Rather than being a traditional composer or instrumentalist, with the Noatikl app you are conductor, director, curator or gardener. You set up
the rules and settings that let it generate a composition for you, in real time, in all its detail. Random events in combination with a powerful set
of musical rules are used to create a stream of music that is ever-changing and continually fresh, but which is entirely in accordance to your
personal artistic choices and musical direction. How you interpret what you hear is filtered through your own internal knowledge of music.
This combination of chance and logic is what allows the music to stay fresh, interesting and unpredictable.

http://intermorphic.com/engine/nme/guide/#scripting-objects
http://intermorphic.com/engine/nme/guide/#file
http://intermorphic.com/engine/nme/guide/#piece-basics
http://intermorphic.com/engine/nme/guide/#the-rules
http://intermorphic.com/engine/nme/guide/#voice-types
http://intermorphic.com/engine/pse/guide
http://intermorphic.com/engine/nme/guide
http://intermorphic.com/engine/nme/guide/#scripting-hyperinstrument
http://intermorphic.com/engine/nme/guide/#scripting
http://intermorphic.com/engine/pse/guide
http://intermorphic.com/engine/nme/guide/
http://intermorphic.com/sseyo/koan
https://en.wikipedia.org/wiki/MIDI
http://intermorphic.com/noatikl/download


3/36

^  ←  →Install & Launch

Noatikl Mobile
Noatikl Mobile for iOS (http://itunes.apple.com/app/id633262318) is installed via the iTunes App Store (https://itunes.apple.com/) as part of the
download process.

Noatikl Desktop user - which variant should you use?

A) Noatikl Desktop Standalone

Use this where:

You have a sequencer which does not support per-channel routing of MIDI data output by a Noatikl Plug-in variant; or

There is no Noatikl plugin variant for your sequencer (e.g. ProTools.); or

You want to create self contained noatikl pieces that use the IM synth

Versions:

Mac - available at the Mac App Store

Windows - available as a 30 day trial from the Intermorphic web store

Noatikl Desktop Standalone runs as a tool on its own, but you can also use it to generate and send MIDI events to a MIDI output device
or virtual MIDI port. You can use it in this manner with any Windows (e.g. Sonar, Reaper, Cubase etc.) or Mac (Logic, Cubase, Pro Tools
etc.) MIDI sequencer (also referred to as a DAW or Digital Audio Workstation) or standalone software synth or sampler.

We have created tutorials and template projects to "get you started"for some of the popular sequencers. Download the file below,
extract the contents to the appropriate place on your computer, and then follow the appropriate tutorial to see how the template project
works:

Logic 8 - template project zip (/noatikl/guide/resources/noatikl_standalone_template_logic_8.zip)

Sonar 6 - template project zip (/noatikl/guide/resources/noatikl_standalone_template_sonar_6.zip)

Cubase SE 3 - template project zip (/noatikl/guide/resources/noatikl_standalone_template_cubase_se_3.zip)

B) Noatikl Desktop Audio Plug-in

Use this where:

You have a sequencer (such as Sonar, Logic or Cubase) which supports per-channel routing of MIDI data output by a Noatikl Plug-
in variant; or

You can set up your sequencer to use a Noatikl VSTi to control multiple synths, all from one instance of Noatikl (depending on
how your sequencer works note timing accuracy might be dependent of the setting for the Noatikl timer resolutions). See Cubase
VSTi video tutorial (/noatikl/#cubase_vsti) or Sonar VSTi video tutorial (/noatikl/#sonar_vsti) for examples.

Versions:

Windows - available as a 30 day trial from the Intermorphic web store

Mac - available for free for Noatikl Mac App Store customers

If you're just using Noatikl to render audio using Noatikl's built-in synthesizer, then there are no special requirements for configuring a
Noaitkl Plug-in variant to work within your DAW. Noatikl will "just work".

However, if you want to process MIDI event data from a Noatikl plug-in variant, then you are likely to have some configuration work to do
first.

Challenge number one: Noatikl emits data for more than one MIDI channel

The most fundamental challenge with the Plug-in variants of Noatikl, is that Noatikl is quite unique in the music world; in that it generates
MIDI data across more than one MIDI channel. Why does this make things difficult? Well, most MIDI Plug-ins are designed to deal with

http://intermorphic.com/noatikl/#sonar_vsti
http://intermorphic.com/noatikl/#cubase_vsti
http://intermorphic.com/noatikl/guide/resources/noatikl_standalone_template_cubase_se_3.zip
http://intermorphic.com/noatikl/guide/resources/noatikl_standalone_template_sonar_6.zip
http://intermorphic.com/noatikl/guide/resources/noatikl_standalone_template_logic_8.zip
https://itunes.apple.com/
http://itunes.apple.com/app/id633262318
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single channels of MIDI data, such as echo or delay effects; or even to generate simple sequences that target a single MIDI channel
(such as standalone bass lines or drum riffs).

However, if you were to assign a Noatikl Plug-in variant to a MIDI track in your sequencer, you would find that you could attach that MIDI
track to render through only one soft synth (such as a VSTi synth). This is not good ... as what you really want to do is render each
channel of data generated by Noatikl through a different synth! Some sequencers are not able to split output from MIDI Plug-ins
attached to a MIDI track, on a per-MIDI channel basis, to target different synthesizers with data from different MIDI channels generated
by noatikl!

That said, many sequencers do work well with the Noatikl VSTi; Reaper, Sonar and Cubase being examples.

Challenge number two: the wide variety of plug-in formats

There is a huge range of plug-in formats, each of which behaves differently on different platforms. Noatikl is a MIDI-based generative
music engine, and therefore is designed to emit (and respond to) MIDI events. However, each sequencer requires a slightly different
variant of plug-in!

If you wish to use Noatikl as a plug-in MIDI event generator, then which plug-in variant to use, depends on what tool you are using, and
which platform you are running on (e.g. Mac OS X or Windows).

Reaper - Noatikl is deployed as a VST plug-in, as Reaper can route MIDI events generated from a VST plug-in into other VSTi
synthesizers. Further info.

Logic / Garageband (for Mac) - Logic (which uses the Audio Unit Format, but which does not support VST plug-ins), simply
doesn’t support MIDI event generation by any Audio Unit plug-in... but we have documented a way to work-around this this. So
you have two options to consider, depending on how you like to work: either use (follow the appropriate link to view the
corresponding tutorial) the Noatikl standalone version or the Noatikl AU version.

Cakewalk Sonar/Home Studio - Noatikl can be deployed in Sonar (Sonar 6 and up) as the Noatikl VSTi. See the video tutorial
(/noatikl/#sonar_vsti) and further info. The output from the Noatikl plug-in this is fed-in to your favourite synthesizer to render the
MIDI events generated by Noatikl using the exact sounds you want. Note that there can be some timing problems inherent in
using the Noatikl VSTi with Sonar; see here (/noatikl/faq/#faq-sonartiming) for more details about how to work-around these
issues.

Cubase SE - Noatikl can be deployed in Cubase (Mac/Windows) as the Noatikl VSTi. See the video tutorial (/noatikl/#cubase_vsti)
and further info. The output from this is fed-in to your favourite VSTi to render the MIDI events using the sounds you want.

Ableton Live - Noatikl is deployed as a VST plug-in, See the video tutorial and further info.

Challenge number three: not all hosts are equal!

Just to add to the challenge, not all hosts handle VSTi plug-ins correctly, and they all have their own ideosyncratic behaviours. So you'll
probably need to experiment to find the Noatikl variant that works best with your favourite host. If in doubt, the standalone Noatikl
version can usually be configured to work well with your sequencer; though the flexibility of the plug-in approach makes it well worth the
effort in giving a plug-in variant of Noatikl a try too!

Noatikl Desktop Standalone and Desktop Audio Plugins
Noatikl Desktop Standalone for Mac OS X (http://itunes.apple.com/app/id665202676) is installed via the Mac App Store
(https://www.apple.com/osx/apps/app-store.html) as part of the download process.

Noatikl Desktop Standalone / Desktop Audio Plugin for Windows are available for downloaded here (/noatikl/download) from the Intermorphic
website as 30 day trial full versions, and are installed as below. See Enter the Product Key on how to unlock them after the trial period is up.

Installing Noatikl Desktop Software Downloaded from IM Website:

Noatikl Desktop Standalone & Desktop Audio Plugin for Windows PC (30 Day Trial Version)

Tip: You cannot install a 32-bit version on a 64-bit OS or vice versa. Get the right version for your OS.

The zip files you can download are called noatikl_win64_standalone_setup.zip  /
noatikl_win32_standalone_setup.zip  or noatikl_win64_plugin_setup.zip  / noatikl_win32_plugin_setup.zip

Unzipping the relevant one for your OS will extract the file e.g. noatikl_win64_standalone_setup.exe  or
noatikl_win64_plugin_setup.exe

Run to install the relevant 64-bit or 32-bit versions of :
noatikl.exe  (standalone)

noatikl_VSTi_win.dll  (VSTi plugin)

http://intermorphic.com/noatikl/download
https://www.apple.com/osx/apps/app-store.html
http://itunes.apple.com/app/id665202676
http://intermorphic.com/noatikl/#cubase_vsti
http://intermorphic.com/noatikl/faq/#faq-sonartiming
http://intermorphic.com/noatikl/#sonar_vsti
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noatikl_VSTi_win.dll  (VSTi plugin)

c:\Program Files\VstPlugIns

If you want to use the Noatikl VSTi, you might need to tell your Sequencer program to scan the appropriate folder for the Noatikl
VSTi, as above.

Note: Earlier versions of the installer used to install on 64-bit Windows a 32-bit plugin to
c:\Program Files (x86)\VstPlugIns , but this is no longer supported.

Configuring your Windows computer so that Noatikl can route its MIDI data

1. Install and enable MIDI Yoke (or other similar software MIDI router such as Maple)
Download MIDI Yoke from http://www.midiox.com/myoke.htm (http://www.midiox.com/myoke.htm)

Install the software!

2. Proving MIDI Yoke works (e.g. in Cubase)
Create a MIDI project

On MIDI track 1 enter some notes with piano roll editor

Set "in:" to "Not Connected"

Set "out:" to one of the virtual MIDI Yoke ports.

On MIDI track 2 set "in:" to the same MIDI Yoke port.

Set "out:" to be your favourite VST Synth or sampler, e.g. "The Grand SE"

Press transport Play, and you should hear your MIDI events being rendered through a soft synth where your MIDI events
have been routed from one track to the other through the MIDI Yoke driver.

Sequencer-specific Plug-in notes
Reaper: How to use the Noatikl VSTi in Reaper

Sonar: How to route MIDI events from the Noatikl VSTi in Sonar

Cubase: How to use the Noatikl VSTi in Cubase

Ableton: How to use the Noatikl VSTi in Ableton

Noatikl Desktop Standalone / Audio Plugin Product Keys for Windows

Noatikl Desktop Standalone & Desktop Audio Plugins for Windows are made available via our website as 30 day trial versions. To
continue to use them after the 30 day evaluation period requires that you purchase the revelant licence(s) from the Intermorphic
webstore (/store). Following your purchase you will be sent an Order Confirmation email that contains your Order ID, Customer ID (the
email you used for purchase) and Product Key, or in some cases just a Product Key.

Note: The Product Key for the Noatikl Desktop Audio Plugin is different to the one for the Noatikl Desktop Standalone version, therefore
you must enter your Product Key into the same product that you have licenced or it will not be accepted. For example, you must enter
the Noatikl Desktop Audio Plugin licence key into the Noatikl Desktop Audio Plugin. To enter your Desktop Audio Plugin product key,
launch the Plugin from your Windows Desktop Audio Workstation (DAW) or Sequencer that is a VST host (e.g. Sonar, Reaper, Ableton,
Cubase etc) and then follow the instructions below.

As you are entering your Product Key into a plugin on a Windows PC, then you might need to ensure that you are running the host
software (e.g. Reaper 3) "as Administrator" in order to get the product key to stick.

Entering the Product Key
Open your Order Confirmation email.

Launch Noatikl
Noatikl Desktop Standalone is launched as you would launch any standalone software.

Noatikl Desktop Audio Plugin must be launched via the VST host you are using it in.

From the Noatikl / Noatikl Plugin Main Menu select Help > Noatikl Product Key.

A dialog box will pop up, and you should copy the relevant information from your Order Confirmation email (i.e. Customer ID,
Order ID and Product Key or where only Product Key is provided, then just that) and paste into the relevant fields. All information
must be the same as that in your Order Confirmation email. If you have problems, see this FAQ entry (/noatikl/faq/#faq-
productkey).

http://intermorphic.com/noatikl/faq/#faq-productkey
http://intermorphic.com/store
http://www.midiox.com/myoke.htm
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Noatikl Desktop Audio Unit Plugin for Mac

As of Noatikl 2.8.1 the Audio Unit plugin no longer requires a Product Key, but instead a Mac App Store purchased and installed version
of Noatikl 2.8+.

IMPORTANT: If you purchased a Noatikl Plugin Licence from the Intermorphic Store but have NOT ALSO purchased Noatikl at
the Mac App Store (and have a Noatikl 2.8+ version installed), then in order to activate the Noatikl Audio Unit Plugin you must
FIRST ensure you have successfully enter your Product Key into a previous version of the Audio Unit Plugin. To check your
license status for the Noatikl Audio Unit Plugin: From the plugin's Menu bar, select Help -> Noatikl Product Key.

Garage Band 10 users: See the following - How do I use Audio Unit plugins (http://thegaragebandguide.com/garageband-10-au-plug-in-
fix)?

The downloaded zip file is called noatikl_AU_mac.component.zip .

Unzipping it will extract the file noatikl_AU_mac.component

Copy or move this file to:

Hard Disk/Library/Audio/Plug-Ins/Components 

Configuring your Mac so that Noatikl can route its MIDI data

Use the following steps, which are also shown in one of the video tutorials (/noatikl/#videos):

1. Enable your IAC driver
Click on the blue magnifying class (spotlight) icon on the top right of your Mac screen

Type "audio midi setup"

Click on the Audio MIDI Setup entry you will see listed under applications. This will run the audio midi setup application.
Note: more advanced Mac users could use Finder to run this application directly, you will find it under Applications /
Utilities Audio MIDI Setup

Click on MIDI Devices tab

Click on IAC Driver

Click on Show Info icon

Ensure that "Device is online" is ticked, and press Apply

2. We strongly recommend that you download and use the excellent MidiPipe by SubtleSoft
(http://homepage.mac.com/nicowald/SubtleSoft/), which you can get from
http://www.apple.com/downloads/macosx/audio/midipipe.html (http://www.apple.com/downloads/macosx/audio/midipipe.html)
... a very useful piece of software, which most of our Mac tutorials rely on! Please also refer to the Noatikl video tutorial -
"creating your first piece on Mac" (/noatikl/#standalone_firstpiece_mac) which will get you going with MidiPipe in 1 minute.

Sequencer-specific Plug-in notes
Reaper: How to use the Noatikl VSTi or Noatikl Audio Unit (AU) in Reaper

Logic: How to use Noatikl AU in Logic

GarageBand: How to use Noatikl AU in GarageBand

Launching Noatikl
iPhone / iPad / iPod touch:

Tap the Noatikl app icon in the App screen.

Desktop PC or Mac:
on Windows PC, select

Start > Programs > Intermorphic > Noatikl

on Mac run

Finder > Applications > Noatikl

Once launched, the load screen will display for a few seconds as Noatikl loads up and show status updates such as "Loading skin" "version
number " and "Loading content". Once Noatikl has loaded the load screen will disappear.

http://intermorphic.com/noatikl/#standalone_firstpiece_mac
http://www.apple.com/downloads/macosx/audio/midipipe.html
http://homepage.mac.com/nicowald/SubtleSoft/
http://intermorphic.com/noatikl/#videos
http://thegaragebandguide.com/garageband-10-au-plug-in-fix
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^  ←  →Copy Content In/Out (Backup)

It may seem odd to put this information right at the top of the guide, but it is because knowing how to back up your creative work (and transfer
to/from device) is so very important and thus needs to be easy to find.

Backing up:

However you use our IM Apps, we strongly recommend you regularly and suitably back up your "Suitable Content" (see below) to
somewhere safe: you don't want to lose it!

IM Apps on Mobile Device: If you have a Mac/Windows PC we strongly recommend you use it to regularly and separately back up
your Mobile Device "Suitable Content" (see below) to an "Intermorphic Folder" (see below) on that Mac/Windows PC. You should
certainly do this BEFORE you remove an IM App from your device or you will lose your files!

iOS specific note: Although making an iTunes backup of your device will back up all your installed apps AND their data (see:
http://support.apple.com/kb/ht4946 (http://support.apple.com/kb/ht4946)), if you remove and then reinstall an app, its DATA is not
restored: the only way to get back that app's data is to do a device restore from a backup (See: http://support.apple.com/kb/HT1766
(http://support.apple.com/kb/HT1766)) - but that also then OVERWRITES ALL device app data with whatever was in the backup. If you
want or need to go that route, see this FAQ entry (/help/index.php/#faq-ios-itunesrestore).

IM Apps

Details in this section apply to Noatikl or Mixtikl ("IM Apps"), as relevant.

Suitable Content:

Noatikl [NT2.5+]

Tiklpak/Pak, .noatikl, .partikl, .fxm, .tg, .DLS, .SF2

Mixtikl [MT6+]
Tiklpak/Pak, .WAV, .Ogg, .MIDI, .mixtikl, .noatikl, .partikl, .fxm, .tg, .DLS, .SF2

Mac / PC - Intermorphic Folder:

Noatikl 2.3+ and Mixtikl 6 (OS X/Windows)

Our Desktop IM Apps save to a specific folder and look for content in that folder. This is to allow Suitable Content (above) to be shared/used
between both mobile and desktop versions of those apps. We call this folder the "Intermorphic Folder". It is a *flat folder* (where tilde [~] or
%HOMEPATH% in the pathname is a shortcut for your user account name), and is found here:

~/Music/Intermorphic/  (Mac)

%HOMEPATH%\Music\Intermorphic  (Windows)

Tip: If you are not sure where to find the Intermorphic Folder, use a Desktop IM App and try saving a .mixtikl or .noatikl file and
then take a look to see what folder it appears in - that is the folder you’re looking for!

If you want to use your own content in IM Apps, or want to move Suitable Content from an earlier version of Mixtikl or Noatikl,
simply move it to the above *flat* folder(s).

IMPORTANT: A flat folder means that *all content* must be at the top level of that folder. It must not be in a subdirectory under it or
it will not be found. So, for example, the free Tiklpak AL Collections 1-3 (/tiklpak/download)zip file would just go here, alongside any
mix files you might have saved or indeed any other content e.g.: ~/Music/Intermorphic/IMTPALLoopEssentials1.zip

Copy: iOS <-> Mac / PC:

Noatikl 2.3+ and Mixtikl 6 (iOS)

Refer to Apple's docs on iTunes Apps File Sharing (https://support.apple.com/en-gb/HT201301), as this is the latest information from them on
how to do this.

Tip: You may need to restart the IM App for it to be able to find any new content copied in.

Tip: You can also email yourself mixes and recordings, and then import from those, but that is something that has to be done one file at
a time.

Note: All Suitable Content is shown in the root directory in the right hand side list. Ignore folders called "CompatibleAppsCache" and
"intermorphic".

Note: Click the following links for information related to Noatikl 2.3 (or earlier) Desktop (OS X/Windows) (/noatikl/faq/#oldAppPaths) or
Mixtikl 5 Desktop (OS X/Windows) (/mixtikl/faq/#oldAppPaths).

Copy: Android <-> Mac / PC:

Mixtikl 6 (Android)

http://intermorphic.com/mixtikl/faq/#oldAppPaths
http://intermorphic.com/noatikl/faq/#oldAppPaths
https://support.apple.com/en-gb/HT201301
http://intermorphic.com/tiklpak/download
http://intermorphic.com/help/index.php/#faq-ios-itunesrestore
http://support.apple.com/kb/HT1766
http://support.apple.com/kb/ht4946
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Connect your Android device to your PC or Mac. It will appear in Explorer or Finder as a USB device.
With Explorer or Finder look for a top level folder on the device or SD card called "Intermorphic" (i.e. NOT /Music/Intermorphic/).
Copy your Suitable Content (see above) to/from this folder. If you want to access the same mixes and recordings in Mixtikl for Desktop, put

them in the Intermorphic Folder (see above) on your Mac/Windows PC.
Tip: You may need to restart Mixtikl for it to be able to find any new content copied in.

TipYou can delete files on your Android device using Menu > Tidy (/mixtikl/guide/#tidy), or by deleting them via Explorer or Finder.

Note: Click the following link for information related to Mixtikl 5 (Android) (/mixtikl/faq/#oldAndroidAppPaths).

http://intermorphic.com/mixtikl/faq/#oldAndroidAppPaths
http://intermorphic.com/mixtikl/guide/#tidy
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^  ←  →Remove Noatikl

Note: If you want to remove Noatikl so you can reinstall an older version, see the instructions here (/noatikl/faq/#faq-reinstall-older-version).

iPhone / iPad / iPod touch:
In the App screen tap and hold the Noatikl application icon, and then press the jiggling black cross in the left corner of it.

PC:
Select the corresponding Uninstall item

Start > Programs > Intermorphic > Noatikl >

Mac:
With Finder, locate the following folders:

1. Hard Disk/Applications

Drag Noatikl  to the Trash

2. Hard Disk/Library/Audio/Plug-Ins/Components

Drag noatikl_AU_mac.component  to the Trash

3. Hard Disk/Library/Audio/Plug-Ins/VST

Drag noatikl_VSTi_mac.vst  to the Trash

http://intermorphic.com/noatikl/faq/#faq-reinstall-older-version
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^  ←  →Quick Start

Tip: If you want some (older) online video tutorials, you can find them here (/noatikl/#videos).

The following short text tutorials are to get you started fast, doing some very basic things with minimum fuss. The principles are the same for
both Noatikl Desktop and Noatikl Mobile (even if slightly different).

Noatikl is a very deep app and quick tutorials are no substitute for further investigation - they are just to get you started! To that end, in most
steps we link to further information where you can go on to read and learn more about various screens and what they are for.

Open, Play a Piece; add a Template Voice; Save piece

1. Launch Noatikl

2. Open a piece:
Mobile: Tap top left Menu icon to take you to the Pieces Screen, and for one of the included demo pieces either double
tap it or tap it to select it and press the top right Open button (folder icon). You may be asked if you want to Open the file
or Add it to any already open piece. Choose the former and the piece will open in Design View.

Were you to already have pieces saved locally, you would go Menu > File > Open and the select a file. Note: The
default folder (/noatikl/guide/#pc) for Noatikl desktop is Mac: ~/Music/Intermorphic/  and Windows:
%HOMEPATH%\Music\Intermorphic .

3. Play the piece:
Mobile: Tap the Play/Stop toggle button in the bottom toolbar

Desktop: Tap the Play/Stop toggle button in the top toolbar

4. Add a Template Voice:
Mobile:

Tap the + button in the bottom toolbar (next to Play/Stop toggle).

In the pop up list, tap any Pak on the left of the list except Noatikl Seed (e.g. DroneMaker1) and on the right tap a
content item (e.g. Drn_M2_mid-ks), which also previews that item (or select Pak "Noatikl Seed" if you want to add a
new default MIDI Voice of one of the Voice Types).

Tap the top right Add item and press OK to add it to the existing piece.

Desktop:
Select any parameter of a Voice you want to add a new Voice AFTER.

Select Menu > New to see the list of Templates available (or select Menu > Edit > Add Voice to add a new default MIDI
Voice)

Tap a content item in the Template list which also previews that item, and then tap the Merge button to add it to the
existing piece.

5. Save your piece:
Mobile: Tap top left Menu icon to take you to the Pieces Screen. Tap in the white box with "untitled" text in it and enter a
name for the piece ("MyPiece"), and then press the Save button to the right of that.

Desktop: Select Menu > File > Save, enter "MyPiece" in the Save As field and find the folder to save it to the default folder
(/noatikl/guide/#pc) for Noatikl desktop being Mac: ~/Music/Intermorphic/  and Windows:
%HOMEPATH%\Music\Intermorphic .

Make a New Piece; assign MIDI channel; change the sound; change track/global FX

1. Launch Noatikl

2. Create a Piece:
Mobile: From the Pieces Screen, tap the + on the bottom toolbar to display the Template list. Tap Standard Templates Pak
on the left, tap Simple File template on the right and then tap the top right New button and you will be returned to the
Design View with a new piece based on that template. Press Play to hear it.

Desktop: Select Menu > New to show the template list and from Built-in select the Simple file template; press the New
button at the top of the template list to be returned to the main screen with a piece based on that template. Press Play to
hear it.

http://intermorphic.com/noatikl/#videos
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3. Assign MIDI channel: Tap and hold the Voice on the left and drag to the MIDI channel 1 box to the right (as you drag all of the
MIDI channel boxes will become visible).

4. Change Wavetable SF2 sound: Tap the Synth box (to the right of the MIDI box) to launch the Partikl Network Editor and in that tap
the purple box marked "1 Wavetable". In the left hand SF2/DLS drop box select IM_Synths.sf2 and in the right Patches drop box
select "VoxA" and (mobile only: press the top left Design press the top left OK buttons twice in a row to return to the Design
Screen with your new sound.

5. Change Track FX: The Track FX (if any) is applied to just the track. Tap the Effect box (to the right of the Synth box) to launch the
Partikl Network Editor and in that tap the top toolbar Folder button to open the FX preset list. Select "Chorus-Strong" and (mobile
only: first press the top left Design button) press the top left OK button to return to the Design Screen with your new FX. Tip: You
can edit

6. Change Global FX: The Global FX (if any) is applied to the whole piece. Tap the Glob FX box (to the right of and above all the
tracks) to launch the Partikl Network Editor and in that tap the top toolbar Folder button to open the FX preset list. Select "Reverb-
9secs" and (mobile only: first press the top left Design button) press the top left OK button to return to the Design Screen with
your new FX.

7. Save your piece: Follow the instructions in the first tutorial and save to "MyPiece2"

Change track volume/pan; track mute/solo; change pitch; export a piece

1. Launch Noatikl

2. Open the piece "MyPiece2" you saved in Tutorial 2 and play it.

3. Change track volume/pan:
Mobile: Tap the bottom tab bar Blend icon to go to the Blend View, then drag the Voice icon around the screen to change
its volume (up/down) and pan (left/right).

Desktop: Volume: In the left hand side Parameter Group display select the "Voice - User Env 1- Volume" parameter group.
In the Envelope parameter control shown on the right, either draw on it with your mouse, or right click on it and select one
of the options. Pan: Select the "Voice - User Env 1 - Pan" parameter instead and change the Envelope parameter control.

4. Change track mute/solo:
Mobile: In the Blend View, tap on a Voice icon and from the pop up control select either Mute or Solo. Tip: You can also
use the Mute or Solo button in the bottom toolbar.

Desktop: Check or uncheck the Mute parameter or, to solo just one Voice, select and hold the keyboard Control key when
you select the Mute parameter.

5. Change Voice pitch:
Mobile: Tap on a Voice icon and from the pop up control select Edit to enter the Voice View. Tap the left hand Basics
group and then in the right of the screen scroll to find the Pitch parameter and use the slider or +/- control to change it.
Tap the bottom Degin tab to return to the Design View.

Desktop: In the left hand side Parameter Group display select the "Voice - Basics" parameter group and then in the right
hand side parameter grid change the value of the Pitch parameter using +/- control or just type a value in that
parameter's grid cell.

6. Export a piece:
Mobile: Tap top left Menu icon to take you to the Pieces Screen. Tap the Export icon in the bottom toolbar and choose
how you want to export it!

Desktop: Select Menu > File > Export > Export with Partikl Sounds and your piece is exported as a URL to the clipboard.
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^  ←  →

Noatikl Start screen

Noatikl Desktop UI

Desktop UI

Noatikl Desktop comes in Standalone and AudioPlugin (VSTi / UAi) versions. It is a deep product and it does take time to master - but it is
worth the effort. This section will go though the main areas of the desktop interface so that you can become familiar with what does what and
we will go on from there.

Note: do also check out Noatikl Mobile, which has the majority of the power of Noatikl Desktop.

Before you start ...
Ensure you have installed Noatikl Desktop and have it correctly setup for MIDI Out if you wish to use that. If you use Logic, also note the special
instructions for Logic.

OK, let's get going!
When you first load Noatikl Desktop you see the following screen which gives you some quick pointers on what to do next:

Playing your first piece
Noatikl Desktop Standalone doesn't come with any demo pieces, but we do have two finished pieces from Tilkbox Relax (/tiklbox/relax) for you
to try out.

To load and play them, you need to do is to have Noatikl Desktop Standalone installed and select the Dropbox links. Once the pieces have
loaded, just press the Noatikl Play button and enjoy!

Tiklbox Calm 5 - Dropbox File (https://www.dropbox.com/s/4ct59c7jd7ijqx2/tiklbox-calm5.noatikl?dl=0) (see FAQ (/help/index.php#faq-
dropbox))

Tiklbox Relax 6 - Dropbox File (https://www.dropbox.com/s/mfq1wizxcv91ik3/tiklbox-relax6.noatikl?dl=0) (see FAQ (/help/index.php#faq-
dropbox))

The screenshot above was taken of Noatikl playing a mix of the two pieces above and it contains a number of generators (voices). This helps
illustrate the different areas in the Desktop interface.

Control Bar

http://intermorphic.com/help/index.php#faq-dropbox
https://www.dropbox.com/s/mfq1wizxcv91ik3/tiklbox-relax6.noatikl?dl=0
http://intermorphic.com/help/index.php#faq-dropbox
https://www.dropbox.com/s/4ct59c7jd7ijqx2/tiklbox-calm5.noatikl?dl=0
http://intermorphic.com/tiklbox/relax
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The top "Control" bar contains the Play/Stop button (press Play to hear Noatikl), as well as information on piece progress, and fast access to
some key MIDI options (as these are very important for many Noatikl users).

Play and Stop

Noatikl Standalone Play

The Play button starts you playing. You will only see this button for Noatikl standalone; for the plug-in variants of Noatikl, play/stop is
controlled directly by your DAW (Digital Audio Workstation)'s transport controls.

Note: you might first want to set-up a MIDI device through which to render your music. See MIDI Routing or MIDI Output for more info
on this.

Note: if you have Sync? selected, then playback won't start making any sounds until the sequencer that you are listening to has the play
button pressed on its own transport control. In this case, you must first press Play before Noatikl can respond to events from your
sequencer's transport control.

Noatikl Standalone Stop

The Stop button stops you playing. You will only see this button for Noatikl standalone; for the plug-in variants of Noatikl, play/stop is
controlled directly by your DAW's transport controls.

Noatikl Plug-in Play and Stop

Press the Play This File! checkbox to indicate which of your open documents is to be played in response to the Transport control in your
DAW. Remember that Noatikl can have more than one document open at once, so this checkbox tells the DAW which of the open
Noatikl files to play.

Progress indicators

When the piece is playing, you will see various interesting properties get displayed in the Playback group:

Tempo

This shows the current Piece tempo. If you are using one of the Noatikl Plug-in variants, then this value will be the value that is forced
by the sequencer host in which Noatikl is running.

Elapsed

The elapsed time in Measures:Beats:Ticks format (MBT).Note that if you are using of of the Noatikl Plug-in variants, then this value
might be up to a bar ahead of the value displayed by your sequencer's transport control; this is because Noatikl composes ahead
according to a latency dictated by the behaviour of your host sequencer.

Percent

The approximate elapsed Noatikl Piece position, relative to the Piece Duration.

MIDI Output

Whether or not you have "Partikl?" checked (which allows sounds and effects to be rendered via the PSE (/engine/pse/guide)), you can
optionally ask Noatikl to deliver MIDI event data from the Voices in your piece to a MIDI Output device.

If you are running within a sequencer which does not support MIDI routing from one VST to another then you must select any value other
than "Sequencer MIDI Pipeline" (otherwise your MIDI events will not generate any sound in the sequencer).

If you are using some other VST Host which allows MIDI data to be routed from one VST into another one (e.g. Reaper), then you may select
any of the available options; though you are most likely to want to select the "Sequencer MIDI Pipeline" option.

Standalone

Mac: select an IAC port, and maybe use MidiPipe by SubtleSoft (http://www.apple.com/downloads/macosx/audio/midipipe.html) to
render your audio data. Please refer to the Noatikl video tutorial - "creating your first piece on Mac"
(/noatikl/#standalone_firstpiece_mac) which will get you going in about 1 minute.

Windows – use a MIDI output device; use MIDI Yoke or Maple if you want to route data from Noatikl to your DAW!

Plug-in

In general, use the "Sequencer MIDI Pipeline" option.

Audio Unit (AU)
See listed IAC Driver Bus 1 (this assumes you have configured the IAC as outlined above) and perhaps some other devices.

VST
Mac: See "Sequencer MIDI Pipeline" followed by Mac - IAC Driver Bus 1

Windows: Use Microsoft GS Wavetable SW Synth or perhaps some other MIDI output devices such as MIDI Yoke channels.

MIDI Input

http://intermorphic.com/noatikl/#standalone_firstpiece_mac
http://www.apple.com/downloads/macosx/audio/midipipe.html
http://intermorphic.com/engine/pse/guide
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You can tell Noatikl to listen-out for incoming MIDI data on the specified port. Noatikl can use incoming MIDI information for various purposes,
including synchronisation and as a hyper-instrument through Listening Voices.

Checkboxes

Partikl?

By default, the "Partikl?" checkbox is ticked. This means that Noatikl will play the MIDI events generated by the generative Voices,
through the built-in PSE (/engine/pse/guide).

If you tick the "Partikl?" checkbox, and have no MIDI Output device specified, Noatikl will send data only to PSE.

If you tick the "Partikl?" checkbox, and set a MIDI Output device, Noatikl will send data simultaneously to both PSE and your MIDI
Output device!

If you clear the "Partikl?" checkbox, Noatikl will only deliver its MIDI output to whatever MIDI Output device you have specified - in
this case, make sure you have a MIDI Output device specified, or you won't hear anything!

Sync?

You can use the Sync feature to allow Noatikl (when playing through an external MIDI device or port) to synchronise with audio
playback in your favourite Sequencer. Once this checkbox is selected, then playback won't start making any sounds until the Sequencer
that you are listening to has the play button pressed on its own transport control.

Note: you will experience a degree of MIDI latency (i.e. all notes offset by a certain amount) and some small variation in the note
playback timing (typically +/- 5 or 10ms). We are looking at ways to minimise this in later updates. If you record the Noatikl output to a
MIDI file, then it is fairly easy to adjust for the latency and also quantise (if you want) the note timing.

Noatikl Standalone

Check the "Sync?" checkbox and set your Noatikl MIDI input device to listen-out to the MIDI port to which you have told your
Sequencer to send MIDI sync information.

Press the Noatikl Play button.

Noatikl will then start and stop playing automatically in response to your pressing the play and stop buttons in the Sequencer.

For an example of setting this us see also this FAQ entry (/noatikl/faq/#faq-sequencermidisync).

Note: Noatikl does not currently support "Resume", so if you press "stop" in your sequencer, then to restart Noatikl you will first
need to rewind your sequencer head to the beginning before pressing "play".

Noatikl Plug-in

Press the play / stop buttons in your transport control.

MIDI Sync using Logic:

Using Logic Pro on the Mac, you can use MidiPipe by SubtleSoft (http://homepage.mac.com/nicowald/SubtleSoft/) to provide the
"cabling" between Noatikl and Logic. Please refer to the Noatikl video tutorial - "creating your first piece on Mac"
(/noatikl/#standalone_firstpiece_mac) which will get you going in 1 minute. Set-up couldn't be easier.

1. Set noatikl's in and out ports to MidiPipe, engage the Sync? option and hit play in noatikl.

2. Open Logic, set the sync option to send midi clock to the MidiPipe port and that's it really. Once you've done that, the Logic
transport controls work both Noatikl and Logic - hit play in Logic and Noatikl starts composing and feeding the tracks in Logic
with midi data. What you do with it then is up to you. Control the tempo of the piece live in real-time from Logic's transport. Or, if
you have them, you can use a hardware transport controller!

Note for Logic 8 Users:

To use MIDI sync in Noatikl AU for Logic 8:

1. Just connect-up IAC1 in the click and port layer... i.e. remove the SUM option... if you don't use the SUM input you need to
connect input ports on a port by port basis. Needs good eyesight and a steady hand if you have a lot of ports.

2. project MIDI sync settings to send to IAC port 2.

3. noatil file: set output IAC1, output IAC 2, sync = checked.

4. Should then work OK.

Listen?

This is provided to protect against MIDI feedback, which can occur with some sequencers, notably Logic (which will by default present
all data output to a port, as an input to all other ports).

If Listen? is ticked or if Noatikl is using the Plug-in internal sequencer pipeline, then:
MIDI events from the MIDI input will be passed-through to Noatikl

the MIDI Input trigger scripts will respond to MIDI input

http://intermorphic.com/noatikl/#standalone_firstpiece_mac
http://homepage.mac.com/nicowald/SubtleSoft/
http://intermorphic.com/noatikl/faq/#faq-sequencermidisync
http://intermorphic.com/engine/pse/guide
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listening voices will compose where appropriate

all note on/off events presented at the input will reach the output.

Noatikl will try to harmonize with incoming MIDI note data.

If Listen? is not selected and if Noatikl is not using the internal sequencer pipeline, then:
MIDI events from the MIDI input will not be passed-through to Noatikl

the MIDI Input trigger scripts will not respond

listening voices will not compose

the only events that will be passed through to Noatikl will be MIDI Sync events

Noatikl will not try to harmonize with incoming MIDI note data.

Noatikl 1.5+, Logic and midi feedback
Noatikl V1.5+ listens to incoming MIDI data to allow you to create dynamic hyperinstruments. In order to use this feature in the
standalone version of Noatikl, Logic users are advised to take the following steps to eliminate the risk of midi feedback.

Voice / Generator Network Editor
The central "Network" editor / panel is where you marry voices (note generators) to MIDI channels, PSE synth sounds and FX. It shows a view
of all NME Voices, together with cells showing the associated MIDI channel and any PSE Synth, Track Effect and Global Effect settings. Refer to
the NME Guide (/engine/nme/guide/) for information on Voice and Piece parameters and the PSE Guide (/engine/pse/guide) for information
on Synth and FX parameters and Networks.

If you drag from a Voice box to a MIDI channel box that will tell the system that the Voice will play through the defined MIDI channel. If a new
voice is added to a piece, the voice won't be assigned to a specific MIDI channel; if you haven't yet hooked-up a Voice to a MIDI channel,
Noatikl will decide on a free MIDI channel to hook-up the Voice to when it starts playing.

Patch and MIDI Channel

The Voice "Patch" parameter defines which MIDI Patch command to send for each MIDI channel - in general, you should only hook-up
multiple Voices to the same MIDI channel if they all share the same Patch parameter.

MIDI Channel 10

MIDI Channel 10 is reserved for the Drum instrument. Every voice with a Drum Patch, should generally be attached to MIDI Channel
10.

Synth

If the "Partikl?" checkbox is checked, then MIDI events are routed for each channel through a PSE (/engine/pse/guide/) configuration
defined by the associated Synth box, which by default will use the PSE's built-in MIDI Wavetable synth (using the Patch defined by the
Voice's Patch parameter). If you want to use a custom sound, click the Synth button to invoke the Synth editor dialog.

Track Effect

The output from every Synth box can be passed through a custom PSE Effect network. If you want to use an Effect, click the Effect
button to invoke the Effect editor dialog!

Global Effect

The output from every PSE Effect is added together and passed through a Global Effect network. If you want to use a Global Effect, click
the "Glob FX" button to invoke the Global Effect editor dialog. This dialog looks the same as for the Track Effect dialog.

By default, the dialog shows no effects units. You can alter the network to use a custom set of sound effects units in various
configurations; or select from a list of built-in preset effects.

Object Type View
The left view lets you select which type of NME Objects you want to edit the parameters for in the Parameter panel below.

NME Voice Objects (/engine/nme/guide/#voice-types)

This is probably the most important Object Type in Noatikl. A Voice is a
Noatikl object that represents a generator of Music data. For example,
a Voice can be used to play a fixed musical pattern. Or, a voice can be
used to create notes according to various musical rules. A Voice can
also be used to emit MIDI controller information that is used to control
your favourite sequencer. You must have at least one Voice in your
Noatikl composition but you may have many more if you want. The
basic behaviour of a Voice is defined by its Voice Type property. You
may tell Noatikl that individual Voices use specific Scale Rules (other
any other of the supported Rules).

http://intermorphic.com/engine/nme/guide/#voice-types
http://intermorphic.com/engine/pse/guide/
http://intermorphic.com/engine/pse/guide
http://intermorphic.com/engine/nme/guide/
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Template List

Empty Piece

NME Rule Objects (/engine/nme/guide/#the-rules)

Scale Rule, Harmony Rule, Next Note Rule and Rhythm Rule. These
rules provide the settings that govern what notes are composed, and
when. Each Voice object can use it own rules, as well the Piece Rules
object (below).

NME Piece Objects (/engine/nme/guide/#piece-basics)

There is always exactly one Piece object in your Noatikl composition.
The Piece object manages various high-level properties of your
composition. These include things like what musical rules to follow by
default (where not overridden by individual Voices), the Tempo to
follow, and various other global properties.

NME File Objects (/engine/nme/guide/#file)

You can store certain basic bookkeeping information related to your
file, such as the title of the composition and the author. The File object
doesn't define any data that affects what you hear in your composition.

NME Parameters View
The bottom "Parameters" view contains a table where you can view
and edit all of the NME Objects and Parameters
(/engine/nme/guide/#scripting-objects) that make-up your Noatikl

composition. It gives you access access to all the editors for the group of objects and parameters you select in the left panel. In the above
picture, the Voices are listed together with their basic parameter values. Voices will flash here to show that they are playing a note.

You can add Voices (or other musical objects) within the table, so that each row represents a different Voice, and each column represents a
different attribute of that Voice. Use the menu items to add, delete and copy voices and other objects.

Creating your first piece with Noatikl Desktop
Open Noatikl, and then From the Noatikl menu, select File -> New.

This presents you with the Template list (first image below) containing a large selection of Noatikl templates from which you may base your
new Noatikl composition.

Select the 'Simple file' item from the list of templates. This will present you with an empty piece (second image below). Then just press Play.

Object Type View

http://intermorphic.com/engine/nme/guide/#scripting-objects
http://intermorphic.com/engine/nme/guide/#file
http://intermorphic.com/engine/nme/guide/#piece-basics
http://intermorphic.com/engine/nme/guide/#the-rules
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^  ←  →Desktop Menus

File Menu
New

Creates a new piece for editing; select the template that you want to use as the basis for your new piece, via the dialog that is
presented to you. Which templates get listed, depends on which template packs you have got installed.

Open...

Browse for a Noatikl or Partikl file to open.

Merge...

Browse for a Noatikl or Partikl template or file to merge into the currently open piece.

From Template

From any installed templates, browse for a template that you want to merge-in to your current piece; Noatikl does the "right thing",
pulling in all voices and rules from that template (it does *not* replace any rules, but will bring-in rules that do not currently exist in
your piece); copies-in all voices and renames each voice if required to keep them unique. Try merging in one or more drum
templates! Note that any sound definitions are not merged in. If you want the sound definitions, you'll need to open a new file from
that template, and export/import the sounds you want using the Synth and Effects cells.

From File

As for Templates, but browse for a Noatikl file that you want to merge-in to your current piece. Try taking any piece, merging-in any
other piece, and amaze yourself at what you hear.

Close

Close the currently open piece.

Save

Save your document as a Partikl file with its current name in its current folder location.

Note: There are two file formats supported by Noatikl 2.

.partikl - Partikl files (e.g. myfile.partikl) contain all the Noatikl parameter definitions and all associated PSE sound & FX definitions.
Partikl files are the primary file format for Noatikl 2. You can change a .partikl file extension to .noatikl and Noatikl will still load it.

.noatikl - Noatikl files (e.g. myfile.noatikl) contain only Noatikl parameter definitions. They do not contain any PSE sound definitions.
Noatikl files were the only file format supported by Noatikl prior to Noatikl 2. The way to create this kind of file is from File > Export
> Noatikl File.

Save As...

Save your document as a Partikl file with a new name or folder location.

Tip: Making/saving your own templates
To create a new Noatikl file which can be used as a template, perhaps one based on the Scale Rules template to which you have
added some of your own rules added, simply save this as e.g. My_Scale Rules.partikl. You can then re-open this whenever you
want, and you can also rename it to a .noatikl file (see above).

Import

Import a Noatikl or Partikl document from the clipboard.

Export...
Export With PSE Sounds

Export your Noatikl rules and all sound settings as a Partikl document to the clipboard.

Save As Noatikl Rules...

Save your file's core Noatikl rules as a Noatikl document with a new name or folder location.

Export Noatikl Rules

Export your file's core Noatikl rules as a Noatikl document on the clipboard.

Open Recent
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Open from a list of your recently accessed Noatikl files (not available in the Mac standalone version).

Edit menu
Use the Edit menu items to copy and paste object parameters. The menu items available under Edit are as follows:

Undo

Where possible, Noatikl presents an Undo option.

Redo

Where possible, Noatikl presents an Redo option.

Add Voice

Adds-in a new default object of the currently viewed type.

Cut Voice

Cuts the currently focused object.

Copy Voice

Copies the currently focused object.

Copy Parameter

Copies the currenly focused parameter.

Paste Voice

Pastes in the most recently copied or cut object or parameter.

Delete Voice

Deletes the currently focused object.

Default Parameter

Restores the currently focused parameter to its default value.

Default Column

Restores all parameters in the currently focused column to their defaults.

Default Row

Restores all parameters in the currently focused row to their defaults.

Control menu
Use the Control menu items to play / stop tracks. The menu items available under Control are as follows:

Play / Stop

Starts or stops the piece playing (you can also use the Ctrl+Spacebar shortcut).

Solo Voice

Solos the selected voice.

Unmute All Voices

Unmutes all voices.

Mute All Voices

Mutes all voices.

Options menu
Check for Updates when Noatikl starts

Select this to allow Noatikl check the Intermorphic website for a simple text file to let it know if there is an update available. Not
available in the Mac Standalone version

Reset Column Widths
Resets the column widths for every parameter, to their default values.

Output Devices
Select your Output audio device to be targeted by Noatikl's built-in PSE synth.
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Tools menu
Use the Tools menu items to access integrated helper utilities. The menu items currently available under Tools are as follows:

Noatikl Script Window

Displays the Noatikl script window.

MIDI File Cooker

Launches a utility to capture (as fast they can be generated) a user configurable number of takes to sequentially numbered MIDI files.
For MIDI file saving, see also Preferences.

Start/Stop

Starts off/stops the "cooking" process (make sure you have a
Noatikl file loaded, and have set the number of "Files to Create"
and "Record MIDI files to folder" below).

Close

Closes the dialog.

Files to Create

Use the slider to select a number from 1-100 (or double click the
number field to enter a number).

Recorded Files

Tells you how many MIDI files have just been recorded.

Recorded

Tells you the total size of the MIDI files that have just been cooked.

View

Uuse this button to see the folder where the recordings are saved.

Important note: when cooking a MIDI file, the tempo comes from the NME Piece Tempo (/engine/nme/guide/#piece-tempo)
parameters; not from any host sequencer.

Show Folders
Show MIDI Recordings Folder

Shows the folder where Noatikl saves MIDI recordings.

Show Noatikl Data Folder

Shows the folder under which Noatikl saves and opens Partikl files such as your custom Synth and Effects networks.

Show Partikl TG Folder

Shows the folder under which Noatikl saves and opens your custom Synth networks.

Show Partikl FX Folder

Shows the folder under which Noatikl saves and opens your custom Effects networks.

~/Library/Noatikl Folder (Mac only)

Displays a pop up with instructions on how to find this folder.

Help menu
Online User Guide

Noatikl Forum

Online Licence

About Noatikl

Noatikl Product Key

Preferences menu
Use the relevant Preferences menu item to define the key settings that the way that Noatikl works. These include settings for MIDI CC Events,
and also to allow automatic MIDI recording of a live playback (see also Tools), as follows:

MIDI File Cooker

http://intermorphic.com/engine/nme/guide/#piece-tempo
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Mac: Noatikl > Preferences...; Windows: Options > Preferences...

Send all CC Events - If you clear this checkbox, the only MIDI CC events
sent by Noatikl will be Bank Select (for patch selection), and those from
Micro Controllers and User Envelopes. The reason for this is to
(optionally) suppress most of the CC messages that Noatikl sends out
as some synths don't seem to like them.

Automatically record to MIDI files? - use this checkbox to enable
automatic recording of Noatikl output to a MIDI file - select the tick box
to enable this behaviour.

View - use this button to see the folder where the automatic MIDI file
recordings are saved.
Note: You wouldn't want to set the auto-record toggle button if you
were using Noatikl for an installation!

Note: when auto-capturing a recording through this preferences
setting, where the tempo comes from depends on what configuration
you are currently using:
- Noatikl Plug-in: the tempo comes from the host
- Noatikl Standalone synced to host:, the tempo comes from the host
- Noatikl Standalone unsynced: Noatikl provides its own tempo from
the from the NME Piece Tempo (/engine/nme/guide/#piece-tempo)
parameters

Preferences Menu

http://intermorphic.com/engine/nme/guide/#piece-tempo
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^  ←  →Desktop MIDI

If you want to send MIDI output from Noatikl to a MIDI port or device, you will need to redirect the "MIDI Output" from Noatikl using a
technique appropriate to your version of Noatikl.

Mac: use an IAC MIDI port; this is built-in to every Mac. As an alternative, you could use MidiPipe by SubtleSoft
(http://homepage.mac.com/nicowald/SubtleSoft/).

Windows: Use MIDI Yoke (http://www.midiox.com/index.htm?http://www.midiox.com/myoke.htm) or Maple virtual MIDI port
(http://www.maplemidi.com/Maple_driver.html).

If you are using a DAW/Sequencer, you must also assign one or more MIDI tracks to listen-out to the port to which you are directing your
Noatikl output! Note that for quick testing of this approach on Windows, you have the option of directly targeting your built-in Windows
wavetable synth.

You'll find a lot of information on how to configure the various variants of Noatikl in the Noatikl FAQ (/noatikl/faq).

What Sequencers support direct sending of MIDI data from Noatikl, onwards to other Instrument Plug-ins?
Reaper for Mac and Windows:

Reaper supports pass-through of MIDI events generated from VSTis

Relevant Noatikl versions:
noatikl_VSTi_win.dll

noatikl_VSTi_mac.vst

noatikl_AU_mac.component

noatikl.exe (standalone Windows)

How to use Noatikl VSTi / AU with Reaper

Reaper is very easy to use with the Noatikl VSTi or Noatikl Audio Unit!

Follow these instructions to get something playing in under two minutes!

1. Run Reaper.

2. New Project (it'll have started with a new project anyways).

3. Track -> Insert New Track.

4. Click the "FX" button in the silvery panel on the LHS side; that panel is basically the controller for the track, the FX is how you
attach FX chains (VST/AU) to the track...

5. Type noatikl in the filter list to make it easy to find...select either the AU or VSTi version of Noatikl, and press OK.

6. In Noatikl, File -> New -> Simple (or open a file you already have).

7. In Reaper, press the play button

Logic / Logic Express / GarageBand for Mac

Logic and Garage Band both support Audio Units

You can also use Noatikl standalone with Logic

Relevant Noatikl versions:
noatikl_AU_mac.component

noatikl.app (standalone)

How to use Noatikl AU with Logic / Garageband

To use Noatikl AU with Logic is very easy; simply download the template project zip
(/noatikl/guide/resources/noatikl_au_template_logic_8.zip) and follow the video tutorial (/noatikl/#logic_au).

http://intermorphic.com/noatikl/#logic_au
http://intermorphic.com/noatikl/guide/resources/noatikl_au_template_logic_8.zip
http://intermorphic.com/noatikl/faq
http://www.maplemidi.com/Maple_driver.html
http://www.midiox.com/index.htm?http://www.midiox.com/myoke.htm
http://homepage.mac.com/nicowald/SubtleSoft/
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Cakewalk (e.g. Sonar, HomeStudio) for Windows:

There are some keyboard issues (/noatikl/faq/#faq-sonar6keyboard) with Sonar 6...

Relevant Noatikl versions:
noatikl.exe (standalone)

noatikl_VSTi_win.dll

How to use Noatikl VSTi with Sonar

Sonar works well with the Noatikl VSTi (albeit with some possible keyboard issues in older versions of Sonar)! There can also be some
timing problems inherent in using the Noatikl VSTi with Sonar; see here (/noatikl/faq/#faq-sonartiming) for more details about how to
work-around these issues.

The steps for using Noatikl VSTi under Sonar Home Studio (which is similar to Sonar Studio/Producer) are as follows (see also the video
tutorial (/noatikl/#sonar_vsti)). These steps might also work (in slightly different form) with earlier versions of Sonar; let us know if you
find out.

Configuring the Noatikl VSTi the first time, for use with Sonar

When you've first copied the Noatikl VSTi to your computer, be sure to scan for the VSTi. On my machine, this involves the following
steps:

Select Tools -> Cakewalk Plug-in Manager from the Menu

In the VST Configuration section, click on the Options button. Add to the list of scan paths, the folder to which you copied the
noatikl_VSTi_win.dll file (on my machine, this is C:\Program Files\Steinberg\Cubase SE 3\Vstplugins, but could also be something
like C:\Program Files\Vstplugins) .

Press the Scan VST Plug-ins button.

Noatikl VSTi_win should now appear in the VST Instruments (VSTi) Plug-in Category.

Using the Noatikl VSTI within your Sonar Project

Step 1: Add the Noatikl VSTi to your project
To add the Noatikl VSTi to your project, do not start by using the synth rack; it will crash Sonar.

Insert the Noatikl VSTi by right-clicking the FX bin of an audio track; select the Noatikl VSTi plug-in.

Load-up a Noatikl file (or create a new one) within noatikl. That will give you something to hear in a moment. Make sure you
set the MIDI Channel parameter for each voice, so you can be sure which software synth you want to direct it to.

Next, open-up the Synth Rack (Views -> Synth Rack)

Right-click on the far-right pane of the Noatikl VSTi, and click on "Enable MIDI Output". This lets Sonar use the MIDI output
data emitted from the VSTi by noatikl. If you forget this step, Noatikl will remain silent.

Close the Synth Rack.

Step 2: Add some Software Synths
Add as many software synths as you want to your Sonar Project; one for every distinct sound you want rendered by your
Noatikl piece. Each software synth is on a separate audio track, of course.

Step 3. Prepare your MIDI tracks.
Create one MIDI track per Noatikl MIDI channel that you're interested in. For every such track:

You must make sure that Input Echo is turned-on! Note: you can see weird behaviour with Sonar, where changing one
MIDI track's Input Echo status can reset the Input Echo status of another track (!); watch-out for this. The way to avoid this
is first to select the Options -> Global -> General menu item, and ensure that the "Always Echo Current MIDI Track" item is
not checked (the default behaviour is that this is checked, which is not what you want).

Select the MIDI Input as the appropriate Noatikl MIDI output (for example, noatikl_VSTi_in 1-> MIDI Ch.1). Set a separate
Noatikl MIDI output channel for each MIDI track.

Set the output device as the appropriate software synth that you added earlier.

We have found that if you should set-up at least some MIDI data in at least one track (such as dummy MIDI controller events),
otherwise the Noatikl data will be ignored! You probably also want to set a loop start and end point (presumably, choosing a
loop size equal to or greater than your Noatikl Piece Length).

Save your project before you forget

Step 4: play and enjoy
Start playback - enjoy what you hear! Note that of course if you have too many software synths in your project, or are running
on a slow computer, you might hear some audio break-up.

http://intermorphic.com/noatikl/#sonar_vsti
http://intermorphic.com/noatikl/faq/#faq-sonartiming
http://intermorphic.com/noatikl/faq/#faq-sonar6keyboard
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Cubase for Mac and Windows:

See the tutorials for hints on how to get started.

Relevant Noatikl versions:
noatikl.exe (standalone Windows)

noatikl.app (standalone Mac)

noatikl_VSTi_win.dll and noatikl_VSTi_mac.vst

How to use Noatikl VSTi with Cubase

Cubase (Windows/Mac) works well with the Noatikl VSTi. The steps for using it with Cubase SE 3 are as follows (see also the video
tutorial (/noatikl/#cubase_vsti)). These steps might also work (in slightly different form) with other Steinberg authoring tools; let us know
if you find out.

Configuring the Noatikl VSTi the first time, for use with Cubase SE 3

When you've first copied the Noatikl VSTi to your computer, be sure to scan for the VSTi.

Using the Noatikl VSTI within your Cubase SE project

Step 1: Add the Noatikl VSTi to your project
To add the Noatikl VSTi to your project, launch the VST Instruments window by selecting Devices -> VST Instruments from the
menu

Insert the Noatikl VSTi by clicking the top area in the first VST instrument slot; select the Noatikl VSTi plug-in (noatikl_VSTi_win
or noatikl_VSTi_mac).

Load-up a Noatikl file (or create a new one) within noatikl. That will give you something to hear in a moment. Make sure you
set the MIDI Channel parameter for each voice, so you can be sure which software synth you want to direct it to.

Step 2: Add some Software Synths
Return to the VST Instruments window.

Add as many software synths as you want to your Project; one for every distinct sound you want rendered by your Noatikl
piece. In the above screen shot, you'll see three soft synths that have been set-up in the VST Instruments window, listed after
the Noatikl VSTi plug-in.

Step 3. Prepare your MIDI tracks.
Create one MIDI track per Noatikl MIDI channel that you're interested in. For every such track:

Select the MIDI Input ("in") as the appropriate Noatikl MIDI output (for example, noatikl_VSTi_win or noatikl_VSTi_mac ).

To ensure that your MIDI track listens-out to only one of the MIDI channels output by Noatikl, select the Input Transformer
button, and select the Local entry in the pop-up list that appears. In the presets drop box, select Channel Filtering followed
by the specific channel that you want to listen to. Finally, set the Active Module 1 checkbox, and close the window. In case
you find these instructions confusing, you should find that they are made clear in the video tutorial (/noatikl/#cubase_vsti).

Set the MIDI Output ("out") to be the appropriate software synth that you added earlier.

You must make sure that Record Enable is turned-o.

Save your project before you forget

Step 4: play and enjoy
Start playback - enjoy what you hear. Note that of course if you have too many software synths in your project, or are running
on a slow computer, you might hear some audio break-up.

Ableton Live for Mac and Windows:

Ableton Live does not supports pass-through of MIDI events generated from VSTis

Relevant Noatikl versions:
noatikl.exe (standalone Windows)

noatikl.app (standalone Mac)

noatikl_VSTi_win.dll and noatikl_VSTi_mac.vst

How to use Noatikl VSTi with Ableton

The steps for using Noatikl VSTi under Ableton Live are as follows; these steps apply to both the Windows and Mac versions of Ableton

http://intermorphic.com/noatikl/#cubase_vsti
http://intermorphic.com/noatikl/#cubase_vsti
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Live.

Configuring the Noatikl VSTi the first time, for use with Ableton Live

When you've first copied the Noatikl VSTi to your computer, be sure to scan for the VSTi from Ableton. Once done, you should see
noatikl_VSTi_win (Windows) or noatikl_VSTi_mac (Mac) in Ableton's list of "Plug-In Devices".

Using the Noatikl VSTI within your Ableton Live Project

Step 1: Add the Noatikl VSTi to your project
Add the Noatikl VSTi by selecting the plug-ins view, and dragging noatikl_VSTi_win (Windows) or noatikl_VSTi_mac (Mac) from
Ableton's list of "Plug-In Devices" on to a MIDI track.

Show the input/output options for your tracks; set the track with Noatikl on it, such that input is set to "No Input".

Show the Noatikl editor window, and set-up a file to play (e.g. create a couple of voices).

Set the Noatikl MIDI Output to be a spare MIDI port; such as MIDI Yoke NT 1 (Windows) or IAC Port 1 (Mac); you can then hide
Noatikl if you want to clear some screen space.

Step 2: Add some Software Synths
Create another MIDI track.

Drag a VSTi synth onto that track.

Make that track's MIDI Input to be the MIDI Port to which Noatikl is sending its data; such as MIDI Yoke NT 1 (Windows) or IAC
Port 1 (Mac) in this example.

Step 3: play and enjoy
Start it all playing

If you can't hear anything, make sure that the green "on" button was set in the bottom panel in Ableton where Noatikl is
shown. If this isn't enabled, you won't see Noatikl flash away when playing notes; so that is a clue to if you need to press this
button or not!

Pro Tools

We are not creating an RTAS plugin at this time, so recommend using Noatikl standalone with Pro Tools.

Relevant Noatikl versions:
noatikl.app (standalone)
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^  ←  →Logic & Noatikl

There is a separate section just for Logic and Noatikl Standalone. This because to run Noatikl under the direct control of Logic's own transport
controls, and also route MIDI event data from Noatikl such that Logic can pick-up that data, requires that a little bit of preparation work is done
first.

Logic sums all incoming midi data to the current active track in the arrange window because this is normally what you might want. However, it
isn't what you want with Noatikl and the Logic manual isn't clear as to how to change this.

Using Noatikl Desktop Standalone application with Logic Pro:

1. Enable IAC bus and assign this as the Noatikl output

2. Launch Logic

3. Select first track in the Arrange window and create an Audio Instrument track.

4. Insert instrument plug-in of choice.

5. Set MIDI channel of this instrument to 1

6. Arm for recording

7. Repeat for up to fifteen other tracks - assigning each one to a different MIDI channel

8. Go to File -> Song Settings -> Recordings

9. Check the box marked "Auto demix by channel if multitrack recording"

This now works correctly i.e. setting Noatikl to transmit on c1 directs the data to the first instrument in Logic, transmitting on c2 goes to the
second etc.

You are now ready to make amazing music with Noatikl and Logic on your Mac.

Noatikl, Logic and MIDI feedback
Noatikl V1.5+ listens to incoming MIDI data to allow you to create dynamic hyperinstruments.

In order to use this feature in the standalone version of Noatikl, Logic users need to take certain steps to eliminate the risk of MIDI feedback.

Due to the way Logic implements it's own MIDI through system, it is essential for Noatikl to use different MIDI ports for MIDI in and MIDI out.
Port sharing will cause MIDI feedback, lockups and the risk of system crashes.

Instructions for using the IAC driver.

Open Audio/MIDI setup in the Applications/Utilities folder. Select the MIDI tab.

Double click on the IAC icon and select Ports Click on the Add port button underneath the ports window. Accept the default setting by clicking
Apply.

In Noatikl select IAC bus 1 as the MIDI output bus and IAC bus 2 as the MIDI input bus

Launch Logic.

Open the Environment window (Command 8) and select the Clicks and Ports layer.

Click on New -> Monitor to create a new Monitor object. Draw a cable from the Midi input object from IAC Bus 2 and connect it to this monitor.
Do not connect the output of this monitor to any other object in the environment.

In the arrange page, select "Settings -> Synchronisation". Click on the MIDI tab. Set the MIDI clock destination tab to be IAC Bus 2 and you are
good to go.

Instructions for MidiPipe

See also: Noatikl video tutorial - "creating your first piece on Mac" (/noatikl/#standalone_firstpiece_mac) which will get you going with MidiPipe
by SubtleSoft (http://homepage.mac.com/nicowald/SubtleSoft/) in 1 minute.

To create a second MidiPipe port, drag another MIDI in and MIDI out into your current pipe.

Select the second MIDI input and click on the blue menu display tab to show all the MIDI inputs. Click on Edit virtual Inputs

Click on New Virtual Input to add the second input, repeat this in the Virtual Outputs view to create a new virtual output. Click Done.

Highlight the first Midi output in the pipe. Ensure the box marked Pass Through is unchecked (this box is checked by default).

Save your Pipe.

In Noatikl select MidiPipe input 1 as the output and MidiPipe Output 2 as the input.

http://homepage.mac.com/nicowald/SubtleSoft/
http://intermorphic.com/noatikl/#standalone_firstpiece_mac
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Instructions for Logic

Launch Logic.

Open the Environment window (Command 8) and select the Clicks and Ports layer.

Click on New -> Monitor to create a new Monitor object. Draw a cable from the MIDI input object from MidiPipe Output 2 and connect it to this
monitor. Do not connect the output of this monitor to any other object in the environment.

In the arrange page, select Settings -> Synchronisation. Click on the MIDI tab. Set the midi clock destination tab to be MidiPipe Input 2
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^  ←  →Mobile UI

Noatikl Mobile for iOS (available at the Apple App Store
(http://itunes.apple.com/app/id633262318)) has all the power of
Noatikl Desktop (including support for PSE Soundfont (SF2) Wavetables
(/engine/pse/guide/#tg-wavetable)) except that it does not support
Scripting or Listening Voices.

That said, it has a useful "Blend" mode for X-Y blending of elements
with a "drift" facility as well as support for Inter-App Audio / Audiobus
and CoreMIDI / Virtual MIDI. As with Noatikl Desktop, Noatikl Mobile
takes a bit of time to master - but it is worth the effort.

This Noatikl Mobile section goes though the main areas of the mobile
interface so that you can become familiar with what does what and we
will go on from there. The parameters are all detailed in the preceding
Noatikl desktop sections.

The "Views"
There are four main "Views" selectable via the bottom tab bar (see
Views below). The first two views are where you design and blend
pieces and are unsurprisingly called the Design and Blend views. The
other two views are the Voices and Piece views, but more on those
later. OK, let's get started, and to do that, we open and play one of the
included demo pieces!

Playing your first piece
Noatikl Mobile comes with two demo pieces; these are finished pieces
that are in Tilkbox Relax (/tiklbox/relax). From either the Design or

Blend view (see Views below), select the top left button which takes you to the Pieces screen. To open one of the Tiklbox pieces either double
tap it or tap it and then tap the top right Open button. To play it, tap the left Play button in the bottom toolbar.

Creating your first piece
The next thing to do is to create your own piece. From either the Design or Blend view (see Views below), select the top left button which takes
you to the Pieces screen.

In the Pieces screen select the top right "New" ("+") button and you are presented with the Template screen containing the list of available
Noatikl templates from which you may base your new Noatikl composition.

Simply select one and press the top right "New" button and you get taken to the Design view - you now have a new piece to edit as you wish!

Design View
The Design view is where you will do your piece construction and set up.

Top Panel

The top panel contains the "Pieces" button on the left and the
"Settings" button on the right.

Piece Status Panel

Below this is the small Piece status panel and this shows the piece
name, elapsed time in Measures:Beats:Ticks format (MBT), elapsed
piece position (%) relative to the piece duration and the piece tempo.

PSE Global Effect Panel
(/engine/pse/guide/#networkeditor)

The output from every Effect is added together and passed through a
Global Effect network. If you want to use a Global Effect, click the "Glob
FX" button to invoke the Global Effect editor dialog. This dialog looks
the same as for the Track Effect dialog.

By default, the dialog shows no effects units. You can alter the network

Noatikl 2 Mobile Load screen

http://intermorphic.com/engine/pse/guide/#networkeditor
http://intermorphic.com/tiklbox/relax
http://intermorphic.com/engine/pse/guide/#tg-wavetable
http://itunes.apple.com/app/id633262318


30/36

to use a custom set of sound effects units in various configurations; or
select from a list of built-in preset effects.

Voice / Generator Network Editor

The central "Network" editor / panel is where you marry voices (note
generators) to MIDI channels, PSE synth sounds and FX
(/engine/pse/guide). It shows a view of all Noatikl NME Voices
(/engine/nme/guide/#voice-types), together with cells showing the
associated MIDI channel and any PSE Synth, Track Effect and Global
Effect settings.

Tap/hold on a voice and you can drag it up/down to change the voice
order. If you drag from a Voice button to a MIDI channel box that will

tell the system that the Voice will play through the defined MIDI channel. If a new voice is added to a piece, the voice won't be assigned to a
specific MIDI channel; if you haven't yet hooked-up a Voice to a MIDI channel, Noatikl will decide on a free MIDI channel to hook-up the Voice to
when it starts playing.

MIDI Channel

The Voice "NME Patch (/engine/nme/guide/#voice_patch)" parameter (see Voices View) defines which MIDI Patch command to send for each
MIDI channel - in general, you should only hook-up multiple Voices to the same MIDI channel if they all share the same Patch parameter.

MIDI Channel 10

MIDI Channel 10 is reserved for the Drum instrument. Every voice with a Drum Patch, should generally be attached to MIDI Channel 10.

Sound Generator

If the "Partikl" toggle is checked in the Settings screen, then MIDI events are routed for each channel through a PSE Synth configuration
defined by the associated Synth box, which by default will use PSE's built-in MIDI Wavetable synth (using the Patch defined by the Voice's Patch
parameter). If you want to use a custom sound, click the Synth button to invoke the Synth editor dialog.

Track Effect

The output from every Synth box can be passed through a custom Effect network. If you want to use an Effect, click the Effect button to invoke
the Effect editor dialog.

Tap on a voice to get a standard iOS pop-up menu (Edit | Mute / Hear | Solo / All | Delete | Copy / Paste). To Paste a voice (once copied) you
must tap an existing voice and then select Paste.

Toolbar

The toolbar contains the Play/Stop control, as well as a button to add templates, buttons for mute and solo screens, and a help/more button.

Views

At the bottom of the screen are 4 tabs that allow you to display the 4 main views, Design, Blend, Voices and Piece.

Blend View
The Blend view is where you will do your piece blending (easily change volume and pan settings) and also have fun with the drifting capability
(where voices can auto blend)!

Top Panel

The top panel contains the "Pieces" button on the left and the "Drift"
button on the right. The 4 Drift options are: Manual (blend), Drift, Flock,
Drift & Flock.

Piece Status Panel

As Design screen.

Central Area

The central area shows the piece voices and you drag them left/right
to change their pan position, or up down to change their volume. Tap
on a voice to get a pop-up menu (Edit | Mute / Hear | Solo / All |
Delete | Copy / Paste | Pin). Selecting Pin will allow you to anchor that
voice so that it will not drift.

Toolbar

As Design view

Views

Design View

http://intermorphic.com/engine/nme/guide/#voice_patch
http://intermorphic.com/engine/nme/guide/#voice-types
http://intermorphic.com/engine/pse/guide
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As Design view.

Voices View
The Voices view is where you edit all the parameter values for each of the voices in the piece. Simply select the Parameter Group on the left
hand side, and then edit the parameters on the right!

Status Bar

Tap this to go back to the top of the list and display the Basics
parameter group.

Voice # Selector

Tap left or right of this to quickly move between NME Voices.

NME Voice Parameter Groups (left panel)

Tap one of the groups to display, on the left, the parameters for that
group. Refer to the NME Guide (/engine/nme/guide/) for information
on Voice parameters.

Piece View
The Piece view is where you edit all the NME Piece parameter values for the piece itself. Simply select the Parameter Group on the left hand
side, and then edit the parameters on the right. Refer to the NME Guide (/engine/nme/guide/) for information on parameters.

Status Bar

Tap this to go back to the top of the list and display the Basics
parameter group.

NME Piece Parameter Groups (left panel)

Tap one of the groups to display, on the left, the parameters for that
group. Refer to the NME Guide (/engine/nme/guide/) for information
on Piece parameters.

Tips

The Piece parameters can make a big difference how your piece
sounds, especially the tempo and root. When exporting a piece for use
in Mixtikl, remember that it is best to use a maximum piece length
(32,000 seconds).

If you are going to be making your piece available for others to use,
you may well wish to include your own copyright statement for the

Blend View

Voices View

http://intermorphic.com/engine/nme/guide/
http://intermorphic.com/engine/nme/guide/
http://intermorphic.com/engine/nme/guide/
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piece. Each voice can also have its own copyright statement.

Pieces Screen
The Pieces screen is where you open / save / create new pieces etc, and also access the list of templates should you want to add one to your
current piece.

Top Panel

On the left of the top panel are the "Design" or "Blend" button on
(depending on how you accessed this screen). On the right is the
"Open" button which will open the selected piece.

Make Copy Panel

The Make Copy panel is where you can save the currently selected
piece to a new name (create a copy). Pressing Save will save the piece
(to back up or transfer this off your iOS device see Copy In/Out).

Piece List

Select a piece in the list and then use the toolbar buttons to carry out
an action on it.

Tip: Double tap a piece to see the option to open it or merge into the
existing piece.

Selected Piece

The selected pieces will be indicated with a highlight.

Toolbar

The toolbar contains the Rename piece button, and buttons to create a
New piece from a template, Export and Import pieces to/from the
clipboard and to Delete pieces.

Tip: When you open a piece, you get presented with an option to merge
it into an existing piece. This can be really useful and fun. Try merging
the two included Tiklbox pieces in this way!

Views

As Design view.

Templates Screen
The Templates screen is where you select and open templates that you want to base a new piece on (when accessed via Pieces screen) or
add to the current piece (when accessed via Design/Blend views).

Top Panel

On the left of the top panel are the "Pieces" button or "Design" or
"Blend" buttons (depending on how you accessed this screen). On the
right is the "New" ("+") or "Add" button (depending on how you
accessed this screen). The New button takes you to the Templates
screen and the Add button takes you back to the view you were last in
(Design or Blend).

Template List

Tap a template to preview it. Tap it again to stop the preview.

Empty Templates

Piece View

Pieces Screen
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There are two simple template that you can choose if you wish as plain
starters.

Voice Type Templates

These let you start a new piece with a particular voice type.

Tiklpak Templates

Noatikl Mobile includes all the template that are in Noatikl, grouped by
Tiklpak. There are a lot of templates, so just scroll down the screen as
you would any list in iOS.

Views

As Design view.

Settings Screen
This screen is where you configure how you want Noatkl to play its

sounds and how to control other apps via Audiobus and Core MIDI.

Top Panel

On the left of the top panel is the "Design" button. On the right is the
"About" button which, when tapped, shows you the Noatikl version
number (also shown on the load screen as Noatikl Mobile loads).

Audio Output

Note: Inter-App Audio and Audiobus (http://audiob.us) are on by
default. To use either of these you need to route Noatikl via an Inter-
App Audio or AudioBus enabled app.

PSE Synth for Sounds & FX (/engine/pse/guide): On by default.
Enables PSE sounds, which all voices use as this is the sound generator
for Noatikl. Turn this to off when you want to play through an external
synth(s) and you do not want to hear the PSE sounds as well. NOTE:
When this is set to OFF you will not hear anything from Noatikl unless
you have a MIDI device connected (and you will hear sounds through
that instead).

Audio Rate: 44 kHz by default. 44 kHz gives the highest quality sound
output from the modular synth (should you be using that). Depending
on how complex your piece is in terms of sounds and FX, however,
older devices might struggle at this output rate. In which case, you can
try reducing how hard Noatikl works the processor by reducing the
output rate to 22 kHz.

MIDI Output

Core MIDI

(http://developer.apple.com/library/ios/#documentation/MusicAudio/Reference/CACoreMIDIRef/): Off by default. When enabled, tells
Noatikl to send-out MIDI events via Core MIDI. Apps that are Core MIDI enabled (http://www.iosmusician.com/app-lists/core-midi) can take
advantage of this.

Virtual MIDI: Off by default. When enabled, causes Noatikl to present a number of Virtual MIDI ports - one Omni (all channels) and 16 per-
channel virtual MIDI ports - and Noatikl sends MIDI events as Virtual MIDI ports over Core MIDI.

MIDI Clock: Off by default. When enabled, tells Noatikl to send-out MIDI Clock events over Core MIDI / Omni channel.

Latency: 100ms by default. Sets Latency (milliseconds) to apply to MIDI events sent-out to Core MIDI / Virtual MIDI by Noatikl. Use to help
remove jitter if using e.g. Network MIDI.

Tuning: Off by default. Useful option for tuning external analog synths - causes all notes sent-out by Noatikl to be "forced" to the specified
pitch.

Rule Editor
This view is where you select and (real-time) edit the Rules used in your voice or piece - be they Scale, Harmony, Next Note or Rhythm rules.

Rule Edit area

This control lets you change the rule elements. Tap on the element to

Templates Screen

Settings Screen

http://www.iosmusician.com/app-lists/core-midi
http://developer.apple.com/library/ios/#documentation/MusicAudio/Reference/CACoreMIDIRef/
http://intermorphic.com/engine/pse/guide
http://audiob.us/
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change its value. The composition engine accomodates all rule
changes in real-time - which can be a lot of fun!

So that you can tell when a voice using the currently selected rule
composes using it, it flashes the colour of the voice type used by that
voice. This is primarily to remind you that other voices rely on that rule,
so if you are going to change it then the way other voices compose
may change, too. It can be useful to have the same rule used by all
voices, but if you want to, then each voice can have its own rule!

Rule List

Below the Rule Edit area is a scrollable list contains all of the defined
rules. Tap a rule to select it so that you can edit it in the Rule Edit area
above.

Toolbar

The toolbar contains the Add Rule button, as well as a the Edit Rule
Name, Cut, Copy and Paste buttons and the Delete button. When you
select the Add Rule button you are presented with a set of included
default rules. For Scale rules these include Major, Minor, Dorian,
Hypodorian, Hypolydian, Hypomixolydian, Hypophyrgian, Lydian,
Mixolydian, Pentatonic, Phrygian.

Edit Pattern View
This view is where you edit all the Pattern parameters. Patterns are a
little tricky to use in the mobile version (because of limited string

editing), so be aware.

Edit Pattern

Tap in the field to edit the NME Pattern or Sub-pattern. The NME
Pattern Syntax (/engine/nme/guide/#voice-type-fixedpattern) can take
a bit of getting used to and you will need to study it carefully if you want
to use patterns.

Toolbar

The toolbar contains the Add Pattern button, as well as a the Up and
Down buttons to move patterns up and down, the Delete pattern
button and the Presets button. Select the Presets button display a list
of preset included patterns to choose from.

IMPORTANT: The pattern you select in the presets list OVERWRITES
your current selected pattern.

Tip

Patterns are a way that can be used to create hidden structure in a
piece. Set up a voice to be of Voice Type Pattern, set its volume to be
zero (e.g. in the Blend view), but do not mute it (or it will not count in
terms of composition). Then, follow that Fixed Pattern voice with
another voice. Set up the following voice with Chords Strategy set to
Chordal Harmony and you will never hear the pattern but it will be
used as an invisible skeleton around which to compose! If you want to
hear the pattern, set Follows Strategy to Semitone Shift.

Rule Editor View

Patterns View

http://intermorphic.com/engine/nme/guide/#voice-type-fixedpattern
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^  ←  →30 Second Videos

iPhone: https://youtu.be/8KSKL_EB2H8 (https://youtu.be/8KSKL_EB2H8)

iPad: https://youtu.be/hbYKbP96vWU (https://youtu.be/hbYKbP96vWU)

See also the list of available Noatikl videos (/noatikl/#videos).

http://intermorphic.com/noatikl/#videos
https://youtu.be/hbYKbP96vWU
https://youtu.be/8KSKL_EB2H8
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^  ←Credits

We have so many people to thank for their support over the years, which has helped us get to where we are today with Noatikl. The list below
is an ever expanding one, in no particular order, and does not include everyone (sorry to those we have missed!):

Everyone who has supported our Noatikl development efforts by purchasing from our store - you are the people who make it all
possible.

Everyone who has made contributions to the Noatikl forum, blogged about our Noatikl products and given feedback.

Those who have helped others on the Noatikl forum, for which we are especially grateful.

Mark Harrop (http://uk.youtube.com/user/UncertainMusicCorps), to whom we are hugely grateful to for his stirling efforts and superb
Noatikl videos.

Timothy Didymus (http://www.myspace.com/timothydidymus), a longstanding friend and colleague with incredible talent whose
sublime generative music creations have, on many occasions when times were hard, given us the much needed inspiration to press
onwards.

Our outstanding early Noatikl beta testers for their testing efforts.

Brian Eno, for his support and kindness to us in the SSEYO Koan (/sseyo/koan) years - he is such an amazing and incredible man and
talent.

Our old friends and colleagues from SSEYO days including Jon Pettigrew, John Wilkinson, Jerry Leach, Paul Blampied, Jerry Swan, Nick
Barefoot, Simon Robertson, Kerry-Anna Saia, Natalie Da Gama Rose, John Tenkoni et al.

http://intermorphic.com/sseyo/koan
http://www.myspace.com/timothydidymus
http://uk.youtube.com/user/UncertainMusicCorps

